Troubleshooting eBooks and eAudiobooks

Are you having trouble using our e-content platform (Overdrive and Libby app)? Try updating your operating system and browser! Here are some tips, and always remember our librarians are here to help with all things tech related to our e-content!

  • Libby’s minimum iOS version is now iOS 10. To use Libby on an iOS device, users are required to update their device’s operating system to iOS 10 or newer. These are the steps to help iOS users update their operating system version.
  • The legacy OverDrive for Mac desktop app is only supported on macOS versions 10.12.1 through 10.14.
  • Users on legacy web browsers may experience issues loading libbyapp.com or your OverDrive website and should upgrade to a newer browser version, if possible.